Gosh, what fun I have had over the last couple of days.

I needed to upgrade SB+ Server 5.3.6 to 5.4. I had so many problems, it was not funny.

These issues are on MS-Windows 2000 Server.

Problem:

The windows install process aborts because the SBDEMO account has a file which the upgrade attempts to create:

 E:SBPLUSSBDEMOCHDEFNS - cannot create a file that already exists 

Fix:

Just restore the SBPLUS directory, move/delete the offending SBDEMO directory/folder/account and start the upgrade again.

Problem:

Entering the SB+ account after the windows install/upgrade to instigate the recovery of the old parameters causes UniVerse to prompt for an update to the SB+ accounts VOC. This then aborts and logs off due to the inability to create some files.

Fix:

The files are not in the VOC but there are in the underlying OS (MS-Windows) so UniVerse attempts to create them but fails. Delete the files/directories from the MS-Windows level and try again. Repeat until it works.

Problem:

I could not print as all the printers had not been started. All the printer info has got lost.

Fix:

Re-enter the ‘Maintain Printers’ information in SB+ Printers Admin.

Problem:

Compiling a report which has been setup to output a PDf comes up with a warning:

 Warning: Variable ORIG.OUT.VALUE' never assigned a value 

Fix

Don’t compile reports!

Problem:

Some derived fields do not work in the report footer line when the report is displayed as HTML or PDF.

Fix:

none – mmm – yet…

A busy night was experienced by all.